Mathadonf de D. Strainchamps

Accueil > Cours magistraux > Bac Pro > Révisions CCF Informatique

Révisions CCF Informatique

mercredi 9 avril 2014, par mathadonf

La fonction SI

Nom des voituresConsommation L/100kmVignette ECO2
206sw 6.4
4007 8.5
Audi A4 12
Twingo 4.5

On veut que la cellule C2 et les suivantes dessous, soit remplie automatiquement par :

- Soit "ECO2" si la consommation est inférieure ou égale à 6,5 L pour 100 km
- Soit "Pollueur" si la consommation est supérieur à 6,5

Pour ce faire on utilise une fonction si

Cette fonction si a trois arguments séparés par deux points virgule

On fait menu insertion fonction, on choisit SI et l’on clique sur suivant

Dans test on écrit : B2<=6.5 (le test est souvent une égalité ou une comparaison entre le contenu d’une cellule donné et un chiffre.

Dans Valeur si vrai : (c’est-à-dire que le test est vérifié) on veut mettre le texte "ECO2" (tout texte dans une formule de calcul est entre guillemets)

Dans Valeur si faux : "Pollueur"

Puis on clique sur ok

La fonction RECHERCHEV

Cette fonction permet de rechercher un texte ou une valeur dans la première colonne d’un tableau et renvoie une cellule dans une colonne adjacente à la cellule trouvée.

Ce que l’on recherche s’appelle le critère recherché c’est une cellule qui n’est en aucun cas dans le tableau où l’on fait la recherche. Je veux dire que pour le critère rechercher on ne clique pas dans le tableau où l’on fait la recherche

Exemple :

Nom Salaire Catégorie {{}} {{}} Tableau des catégories
Vincent 850 Salaires Catégories
Jean-luc 1500 0 D
David 2000 900 C
Claire 1700 1500 B
Chantal 3120 3000 A

Dans la cellule C2 on fait insertion fonction RECHERCHEV suivant

Ce que l’on recherche c’est le contenu de la cellule B2 (850) c’est le critère recherché. La matrice c’est le tableau où l’on recherche B2 : donc c’est D2:E6 que l’on change en $D$2 :$E$6 pour que lorsque l’on copiera la cellule le tableau reste fixe. L’indice est un nombre : ici 2 car la catégorie que l’on recherche est dans la deuxième colonne de la matrice.

On obtient :

=RECHERCHEV(B2 ;$F$2 :$G$6 ;2)

B2 n’est pas dans le tableau donc la fonction recherchev renvoie la cellule juste en dessous du nombre le plus approchant.

La fonction VPM :

Elle permet de calculer le montant d’un emprunt à annuités constantes

Durée en annéeTaux annuelMontant empruntéAnnuité
25 4% 150000

Dans la cellule D2 on fait insertion fonction VPM Suivant

Pour Taux : B2/12 car il faut un taux mensuel

Pour NPM : A2*12 car ce sont des mensualités que l’on calcule

Pour VA : C2

on obtient :

=VPM(B2/12 ;A2*12 ;C2)